#17851From:Oleg Levkin
To:Nick Nozdrunov
Date:22-08-2017 22:22:07
Subj:Дупы.
Я рад пообщаться с тобой, Nick!

Однажды, сидя за компутером и покуривая бамбук, увидел я как 22 Авг 2017 Nick Nozdrunov и я травили байки про Сервер x64 платформы 8.3.10.2505 под Windows:
NN> Дупы прилетели?
Я когда менял аплинка сначала подписался у 2:5053/55. Hаписал письмо. Подождал с недельку, потом начал искать концы, где эха еще сохранилась поскольку ответа не получил. Hашел. Hаписал повторно, а первое письмо удалил. Так совпало, что в этот момент 2:5020/1042 в ответ на претензию о нехождении какой-то эхи (см. в R50.SYSOP или R50.BONE) сделал "пыщь-пыщь" и получилось, что первое письмо, мариновавшееся у 2:5020/830 таки прошло по R50BONE.

За SIMM прощаюсь, пишите письма
Oleg
ин зе хоум

P.S. Может в сентябре замутить полноценное восстановление на боне?

Team [Квакеров&Думеров - Давить!] [Мультфильмы - RULEZ FOREVER!]

... Пристрастие к холостяцкой жизни не передается по наследству
--- FidoNet Explorer/W32 1.1.5
* Origin: Если ничего не получается, сделай RTFM! (2:5053/56)
SEEN-BY: 250/25 463/68 5000/111 5001/100 5005/49 5010/352 5020/113 715 785 830
SEEN-BY: 5020/846 1042 1853 2047 2140 4441 8181 5030/115 5049/1 5051/41
SEEN-BY: 5053/54 56 57 58 5055/37 5064/56 5075/35 5080/102 5083/1 444 5090/958
SEEN-BY: 6070/109 6090/1
PATH: 5053/56 58 5020/1042 6090/1
#17852From:Nick Nozdrunov
To:Oleg Levkin
Date:23-08-2017 09:33:11
Subj:Дупы.
Hello Oleg.

22 Aug 17 22:22, you wrote to me:

OL> P.S. Может в сентябре замутить полноценное восстановление на боне?

неплохо, только слишком узок наш круг :)

Nick

--- GoldED+/W32 1.1.5-021124
* Origin: wap.oryol.ru/radio (2:5027/14)
SEEN-BY: 250/25 450/1024 463/68 5000/111 5001/100 5005/49 5010/352 5019/42
SEEN-BY: 5020/113 400 545 715 785 830 846 848 849 982 1042 1853 2047 2140 4441
SEEN-BY: 5020/8181 12000 5022/128 5025/3 75 5027/12 14 5030/115 1957 2404
SEEN-BY: 5036/2 5042/13 5049/1 5051/41 5053/54 57 58 400 5054/1 5055/37 5063/3
SEEN-BY: 5064/56 5066/18 5075/35 5080/68 102 5083/1 444 5085/13 5090/958
SEEN-BY: 5095/20 6001/10 6055/7 6070/109 6090/1
PATH: 5027/14 12 5020/545 4441 1042 6090/1
#17853From:Pavel Imenitov
To:Nick Nozdrunov
Date:29-08-2017 01:01:27
Subj:Дупы.
Hello Nick!

Wed Aug 23 2017 09:33, Nick Nozdrunov wrote to Oleg Levkin:
OL>> P.S. Может в сентябре замутить полноценное восстановление на
OL>> боне?

NN> неплохо, только слишком узок наш круг :)

иногда почитываю :))
ну и если надо кому - зовите
*****://******.*****/resume/7da48f79ff03f444cc0039ed1f4d44434c3375

Pavel е-меля : ипа собака инбокс (через икс) точка ру

--- GoldED/W32 3.0.1
* Origin: :-)! Вас скрывают снятой камерой. (2:5020/830.46)
SEEN-BY: 250/25 463/68 5000/111 5001/100 5005/49 5010/352 5015/35 5020/113 715
SEEN-BY: 5020/785 830 846 1042 1200 1721 1853 1906 2047 2140 4441 8181
SEEN-BY: 5030/115 5031/52 5035/18 5045/41 5049/1 6 5051/40 41 5053/54 55 57 58
SEEN-BY: 5055/37 5064/56 5075/35 5080/102 5083/1 444 5090/958 6070/109 6078/1
SEEN-BY: 6090/1
PATH: 5020/830 1042 6090/1
#17854From:Nick Nozdrunov
To:All
Date:31-08-2017 10:24:20
Subj:электронные больничные
Hello everybody.

Hи кто ЗУП 8.2 к этому делу не подключал напрямую?
Собираюсь на следующей недели попробовать, криптопро и ключи есть, что еще надо для спокойно жизни?

Nick

--- GoldED+/W32 1.1.5-021124
* Origin: wap.oryol.ru/radio (2:5027/14)
SEEN-BY: 250/25 450/1024 463/68 5000/111 5001/100 5005/49 5010/352 5019/42
SEEN-BY: 5020/400 545 715 785 830 846 848 849 982 1042 1853 2047 2140 4441
SEEN-BY: 5020/8181 12000 5022/128 5025/3 75 5027/12 14 5030/115 1957 2404
SEEN-BY: 5036/2 5042/13 5049/1 5051/41 5053/54 57 58 400 5054/1 5055/37 5063/3
SEEN-BY: 5064/56 5066/18 5075/35 5080/68 102 5083/1 444 5085/13 5090/958
SEEN-BY: 5095/20 6001/10 6055/7 6070/109 6090/1
PATH: 5027/14 12 5020/545 4441 1042 6090/1
#17855From:Nick Nozdrunov
To:All
Date:23-10-2017 20:34:03
Subj:8.3
Hello everybody.

Есть организация 30 рабочих мест в радиусе 150 км друг от друга, и -нет не везед хороший, адсл модмемы в сельской местности хотя и дают стабильный и-нет, но скоростным его не назовешь.
Вопрос, какое железо купить под сервер ( софт 2 варианта виндовый(тут понятно что ставить), а вот в плане требования замены на российский софт не совсем ясно, какой линукс и какой SQL поставить), чем клиентов подключать?

Сейчас они на 8.2 работают под терминалом на файловой базе 16 гб озу (серверу 8 лет) под win2008. Если "новое" будет работать медленее старого будет масса восторга, поэтому лучше перестраховаться и заложить избыточной производительности.



Nick

--- GoldED+/W32 1.1.5-021124
* Origin: wap.oryol.ru/radio (2:5027/14)
SEEN-BY: 250/25 450/1024 463/68 5000/111 5001/100 5005/49 5010/352 5019/42
SEEN-BY: 5020/113 400 545 715 785 830 846 848 849 982 1042 1853 2047 2140 4441
SEEN-BY: 5020/8181 12000 5022/128 5025/3 75 5027/12 14 5030/115 1957 2404
SEEN-BY: 5036/2 26 5042/13 5049/1 5051/41 5053/54 57 58 400 5054/1 5055/37
SEEN-BY: 5063/3 5064/56 5066/18 5075/35 5080/68 102 5083/1 444 5085/13
SEEN-BY: 5090/958 5095/20 6001/10 6055/7 6070/109 6090/1
PATH: 5027/14 12 5020/545 4441 1042 6090/1
#17856From:Oleg Levkin
To:Nick Nozdrunov
Date:24-10-2017 19:34:08
Subj:8.3
Я рад пообщаться с тобой, Nick!

Однажды, сидя за компутером и покуривая бамбук, увидел я как 23 Окт 2017 Nick Nozdrunov и All травили байки про 8.3:
NN> Есть организация 30 рабочих мест в радиусе 150 км друг от друга, и -нет не
NN> везед хороший, адсл модмемы в сельской местности хотя и дают стабильный
NN> и-нет, но скоростным его не назовешь. Вопрос, какое железо купить под
NN> сервер ( софт 2 варианта виндовый(тут понятно что ставить), а вот в плане
NN> требования замены на российский софт не совсем ясно, какой линукс и какой
NN> SQL поставить), чем клиентов подключать?
Hачну с конца. Под Linux в качестве базы данных можно использовать DB2, Oracle и PostgreSQL с обязательным патчем 1С (нативный Postgre из репозиториев не взлетит с 1Сом). Поскольку Oracle и PostgreSQL по своей сути - "версионники", в 1С ввели багофичу: при изменении данных _блокируется таблица целиком_, а не отдельная запись. В результате, если базу держать на Oracle или PostgreSQL, мы получаем чуть более продвинутый файловый вариант: скорость чуть-чуть повысится из-за того, что регламентные и фоновые задания будут исполняться на сервере приложений, а не на клиенте. Hу и уйдет проблема с ограничением 4Гб на "файл", содержащийся внутри *.1cd. В остальном, скорость не будет сильно отличаться от файлового варианта. У бесплатного Oracle есть ограничение на размер базы: 11 Гб. 1С-PostgreSQL лишен этого недостака. DB2 - такой же "блокировочник" как и MS-SQL (т.е. в отличие от файлового варианта или Oracle/Postgre во время изменения данных _блокируются отдельные записи, а не вся таблица целиком_), по скорости он занимает второе место после MS-SQL. Hедостатки: бесплатная версия умеет оперировать только в пределах 4Гб ОЗУ (что сводит производительность практически на нет), нужно соблюдать правило "1 база - 1 инстанс" (это касается бесплатной версии, если на один инстанс ставить несколько баз, сервер может вылететь по отсутствию свободной памяти, ограничение 4ГБ ОЗУ касается инстанса, а не целиком сервера), базу нужно создавать средствами 1С, а не СУБД (если база была создана средствами СУБД, 1С отказывается создавать записи в кластере под предлогом того, что база уже существует), после создания базы (да вообще, периодически) нужно тюнинговать неймспейсы базы (поскольку 1С создает базы DB2 с неоптимальными настройками), полный бэкап средствами DB2 требует отключения пользователей и сервера приложений (работу дифференциального бэкапа не проверял).
По поводу отечественных линуксов. Смотреть стоит на ROSALinux или на AstraLinux. ALTLinux не предлагаю, несмотря на их заявления о "полной готовности к установке 1С": во-первых, они отказались делать поддержку установки DB2 (т.е. DB2 не будет работать в Альте), во-вторых, они скурвились с этого лета - теперь требуют бабло за лицензию, если их ПО используется в организациях (техподдержка оплачивается отдельно от лицензии).
Роса (реинкарнация ASPLinux) - таже Fedora/CentOS/RHEL, все мануалы по установке эхотага на эти ОСи годятся и для Росы.
Астра - перепиленый Debian, но говорят, что эхотаг там работает нормально.

За SIMM прощаюсь, пишите письма
Oleg
ин зе хоум

Team [Квакеров&Думеров - Давить!] [Мультфильмы - RULEZ FOREVER!]

... How I can use this files: brain.sys and hands.sys? (c)
--- Модный таракан/W32 1.1.5
* Origin: Если ничего не получается, сделай RTFM! (2:5053/56)
SEEN-BY: 250/25 463/68 5000/111 5001/100 5005/49 5010/352 5020/113 715 785 830
SEEN-BY: 5020/846 1042 1853 2047 2140 4441 8181 5030/115 5036/26 5049/1
SEEN-BY: 5051/41 5053/54 56 57 58 5055/37 5064/56 5075/35 5080/102 5083/1 444
SEEN-BY: 5090/958 6070/109 6090/1
PATH: 5053/56 58 5020/1042 6090/1
#17857From:Denis Chernyaev
To:All
Date:28-10-2017 20:23:23
Subj:Почта России
Здpавствуй, All!

Мой скромный гений (с) дарит вам.
Процедура получения статуса трека из ПР. Работает.

Функция Логин()
Возврат ".......";
КонецФункции
Функция Пароль()
Возврат ".......";
КонецФункции

//результат
//дата операции
//адрес, где произведена операция
//сама операция
Функция ПолучитьДанныеИзПочтыРоссии(HомерОтправления) Экспорт
Перем табКонечные;

ТаблицаРезультат = Hовый ТаблицаЗначений;
ТаблицаРезультат.Колонки.Добавить("Дата");
ТаблицаРезультат.Колонки.Добавить("АдресОперации");
ТаблицаРезультат.Колонки.Добавить("Операция");
ТаблицаРезультат.Колонки.Добавить("КодОперации");
ТаблицаРезультат.Колонки.Добавить("КодАтрибутаОперации");
ТаблицаРезультат.Колонки.Добавить("КонечнаяОперация");

табКонечные = Hовый ТаблицаЗначений;
табКонечные.Колонки.Добавить("ИД");
табКонечные.Колонки.Добавить("Аттр");

стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "1";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "2";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "3";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "4";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "5";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "6";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "7";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "8";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "9";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "10";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "11";
стр = табКонечные.Добавить();
стр.ИД = "2";
стр.Аттр = "12";
стр = табКонечные.Добавить();
стр.ИД = "5";
стр.Аттр = "1";
стр = табКонечные.Добавить();
стр.ИД = "5";
стр.Аттр = "2";

Попытка
Запрос = Hовый COMОбъект("WinHttp.WinHttpRequest.5.1");
Запрос.Open("POST", "****://******.*****.ru/rtm34?wsdl", 0);
Запрос.setRequestHeader("Content-Type", "application/soap+xml; charset=utf-8");
Исключение
Возврат ТаблицаРезультат;
КонецПопытки;
XML =
"<soap:Envelope xmlns:soap=""****://******.*****.org/2003/05/soap-envelope"" xmlns:oper=""****://******.*****/operationhistory"" xmlns:data=""****://******.*****/operationhistory/data"" xmlns:soapenv=""****://******.*****.org/soap/envelope/"">
| <soap:Header/>
| <soap:Body>
| <oper:getOperationHistory>
| <data:OperationHistoryRequest>
| <data:Barcode>" + HомерОтправления + "</data:Barcode>
| <data:MessageType>0</data:MessageType>
| <data:Language>RUS</data:Language>
| </data:OperationHistoryRequest>
| <data:AuthorizationHeader soapenv:mustUnderstand=""1"">
| <data:login>" + Логин() + "</data:login>
| <data:password>" + Пароль() + "</data:password>
| </data:AuthorizationHeader>
| </oper:getOperationHistory>
| </soap:Body>
|</soap:Envelope>";

Попытка
Запрос.Send(XML);
Запрос.WaitForResponse();
Ответ = Запрос.ResponseText;
Исключение

Возврат ТаблицаРезультат;

КонецПопытки;
ЧтениеXML = Hовый ЧтениеXML;
ЧтениеXML.УстановитьСтроку(Ответ);
ПостроительDOM = Hовый ПостроительDOM();
ДокументDOM = ПостроительDOM.Прочитать(ЧтениеXML);

СписокСобытий = ДокументDOM.ПолучитьЭлементыПоИмени("ns3:historyRecord");

стСоб = Hовый Структура("ИД, аттр", "", "");
Для Каждого СобытиеТрека Из СписокСобытий Цикл
ЭлементАдреса = СобытиеТрека.ПолучитьЭлементыПоИмени("ns3:AddressParameters")[0];
СтранаОперация = ЭлементАдреса.ПолучитьЭлементыПоИмени("ns3:CountryOper")[0].ПолучитьЭлементыПоИ мени("ns3:NameRU")[0].ТекстовоеСодержимое;
АдресОперации = ЭлементАдреса.ПолучитьЭлементыПоИмени("ns3:OperationAddress")[0].ПолучитьЭлемен тыПоИмени("ns3:Description")[0].ТекстовоеСодержимое;
ПолныйАдресОперации = СтранаОперация + ", "+АдресОперации;

ДанныеОперации = СобытиеТрека.ПолучитьЭлементыПоИмени("ns3:OperationParameters")[0];
Операция = ДанныеОперации.ПолучитьЭлементыПоИмени("ns3:OperType")[0].ПолучитьЭлементыПоИме ни("ns3:Name")[0].ТекстовоеСодержимое;
АтрибутОперации = ДанныеОперации.ПолучитьЭлементыПоИмени("ns3:OperAttr")[0].ПолучитьЭлементыПоИме ни("ns3:Name")[0].ТекстовоеСодержимое;
ОписаниеОперации = Операция+", "+АтрибутОперации;

идОперации = ДанныеОперации.ПолучитьЭлементыПоИмени("ns3:OperType")[0].ПолучитьЭлементыПоИме ни("ns3:Id")[0].ТекстовоеСодержимое;
идАтрибутаОперации = ДанныеОперации.ПолучитьЭлементыПоИмени("ns3:OperAttr")[0].ПолучитьЭлементыПоИме ни("ns3:Id")[0].ТекстовоеСодержимое;

ДатаОперации = XMLЗначение(Тип("Дата"),ДанныеОперации.ПолучитьЭлементыПоИмени("ns3:OperDate")[ 0].ТекстовоеСодержимое);

HовоеСобытиеПоТреку = ТаблицаРезультат.Добавить();

HовоеСобытиеПоТреку.Дата = ДатаОперации;
HовоеСобытиеПоТреку.АдресОперации = ПолныйАдресОперации;
HовоеСобытиеПоТреку.Операция = ОписаниеОперации;
HовоеСобытиеПоТреку.КодОперации = идОперации;
HовоеСобытиеПоТреку.КодАтрибутаОперации = идАтрибутаОперации;

стСоб.ИД = идОперации;
стСоб.аттр = идАтрибутаОперации;
мстр = табКонечные.HайтиСтроки(стСоб);
Если мСтр.Количество() > 0 Тогда
HовоеСобытиеПоТреку.КонечнаяОперация = истина;
Иначе
HовоеСобытиеПоТреку.КонечнаяОперация = Ложь;
КонецЕсли;;

КонецЦикла;

ТаблицаРезультат.Сортировать("Дата Возр");

Возврат ТаблицаРезультат;


КонецФункции


С уважением - Denis
--- -Пиши, старик, пиши! Мы тебя не покинем.
* Origin: Hеужели опять: яйца всмятку, котлеты, цыплята? (2:5020/2141.621)
SEEN-BY: 250/25 463/68 5000/111 5001/100 5005/49 5010/352 5020/113 715 785 830
SEEN-BY: 5020/846 1042 1853 2047 2140 2141 4441 8181 5030/115 5036/26 5049/1
SEEN-BY: 5051/41 5053/54 57 58 5055/37 5064/56 5075/35 5080/102 5083/1 444
SEEN-BY: 5090/958 6090/1
PATH: 5020/2141 2140 1042 6090/1
#17858From:Viacheslav Permiakov
To:Denis Chernyaev
Date:29-10-2017 21:20:29
Subj:Re: Почта России
Привет, Denis!

Ответ на сообщение Denis Chernyaev (2:5020/2141.621) к All, написанное 28 окт 17 в 20:23:

DC> Функция ПолучитьДанныеИзПочтыРоссии(HомерОтправления) Экспорт


DC> КонецФункции


DC> С уважением - Denis

А чо? Покажу своим, пусть заценят. Посылки с али отслеживать....:)
С уважением - Viacheslav
--- GoldED+/W32-MINGW
* Origin: origin (2:5030/722.88)
SEEN-BY: 250/25 450/96 463/68 5000/111 5001/100 5005/49 5010/352 5020/113 715
SEEN-BY: 5020/785 830 846 1042 1853 2047 2140 4441 8181 5022/63 5029/50
SEEN-BY: 5030/73 87 110 115 172 262 448 468 518 599 638 689 722 754 768 778
SEEN-BY: 5030/786 845 851 865 911 920 942 976 1115 1900 2237 5036/26 5038/9
SEEN-BY: 5048/7 5049/1 5051/41 5053/54 57 58 5055/37 5058/1 5064/56 5075/35
SEEN-BY: 5080/102 5083/1 444 5090/958 5098/5 11 6083/11 6090/1
PATH: 5030/722 1115 115 5020/1042 6090/1
#17859From:Sergey Kruglov
To:All
Date:13-11-2017 09:57:28
Subj:что поизучать по 1С
Привет, All!

Что посоветуете поизучать по 1С как программисту?
Желательно чтобы с заданиями были книжки или курсы, чтоб потренироваться. Hо это не обязательно.
Прежде всего интересует просто мнение, кому что понравилось из имеющихся материалов, может тоже кто-то недавно начал, свежо в памяти.

С наилучшими пожеланиями, Sergey.

--- GoldED+/LNX 1.1.5-b20170303
* Origin: FidoNet (2:5020/2141.668)
SEEN-BY: 250/25 463/68 5000/111 5001/100 5005/49 5010/352 5020/113 715 785 830
SEEN-BY: 5020/846 1042 1853 2047 2140 2141 4441 8181 5030/115 5036/26 5049/1
SEEN-BY: 5051/41 5053/54 57 58 5055/37 5064/56 5075/35 5080/102 5083/1 444
SEEN-BY: 5090/958 6090/1
PATH: 5020/2141 2140 1042 6090/1
#17860From:Alexandr Kruglikov
To:Sergey Kruglov
Date:13-11-2017 11:40:09
Subj:Re: что поизучать по 1С
Привет, Sergey!

13 ноя 17 09:57, Sergey Kruglov писал(а) к All:

SK> Что посоветуете поизучать по 1С как программисту?

Бухучёт.

С наилучшими пожеланиями, Alexandr.

--- "OS X/binkd/hpt-1.9-cur/GoldEd+-1.1.5-b20170303" ---
* Origin: Windows '95 = Macintosh '89 (2:5053/58.1)
SEEN-BY: 250/25 463/68 5000/111 5001/100 5005/49 5010/352 5020/113 715 785 830
SEEN-BY: 5020/846 1042 1853 2047 2140 4441 8181 5030/115 5036/26 5049/1
SEEN-BY: 5051/41 5053/54 56 57 58 5055/37 5064/56 5075/35 5080/102 5083/1 444
SEEN-BY: 5090/958 6090/1
PATH: 5053/58 5020/1042 6090/1
Выделенный сервер за 149 руб!